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Problem description

We cannot use MS Teams and Ringotel simultaneously. If we are in a Teams meeting and receive a call on Ringotel, the Teams meeting is terminated. Similarly, if we are using Ringotel to communicate with a customer and someone calls us via Teams, the Ringotel call is disconnected.

Explanation

It turn out to be a known issue with MS Teams and VoIP applications. You can check, for example, this thread for a number of similar complains with other VoIP applications: https://answers.microsoft.com/en-us/msteams/forum/all/teams-call-will-drop-when-i-receive-a-call-from-a/b589bbe5-505a-46ec-9b0c-fc956d8f9620

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Issue Description

When users have both the Ringotel App and the MS Teams App running simultaneously, disconnecting a call on one app may drop the call on the other app.

Cause

This interference has been found due to the Sync Device Buttons setting in MS Teams. This setting is turned on by default as shown below.

Solution

Presently, there are two methods available to prevent this behavior:

Method 1

Disable “Sync device buttons“ option in the Teams settings. Based on the Microsoft blog post, the “Sync device buttons” toggle available under your Teams Desktop client Settings (Devices tab) allows users to disable the syncing between their device controls and with Teams. The purpose of this feature is to offer an option for end users to disable the syncing of their connected Peripherals with the Teams Desktop client to allow for co-existence scenarios with other HID-enabled or speech-recognition apps.

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Method 2

Enable “Ignore the end call event from the headset“ in the Ringotel desktop app Settings (Menu → Settings → General tab). With this option disabled, the Ringotel app will disregard the received end call HID commands from the headset. This helps to prevent situations where an incoming call on Teams terminates an active call on Ringotel.

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