Calls drop immediately a Teams call is received
Issue Description
When users have both the Ringotel App and the MS Teams App running simultaneously, disconnecting a call on one app may drop the call on the other app.
Cause
This interference has been found due to the Sync Device Buttons setting in MS Teams. This setting is turned on by default as shown below.
Solution
Presently, there are two methods available to prevent this behavior:
Method 1
Disable “Sync device buttons“ option in the Teams settings. Based on the Microsoft blog post, the “Sync device buttons” toggle available under your Teams Desktop client Settings (Devices tab) allows users to disable the syncing between their device controls and with Teams. The purpose of this feature is to offer an option for end users to disable the syncing of their connected Peripherals with the Teams Desktop client to allow for co-existence scenarios with other HID-enabled or speech-recognition apps.
Method 2
Enable “Ignore the end call event from the headset“ in the Ringotel desktop app Settings (Menu → Settings → General tab). With this option disabled, the Ringotel app will disregard the received end call HID commands from the headset. This helps to prevent situations where an incoming call on Teams terminates an active call on Ringotel.
Additional notes
Ringotel call gets disconnected the moment the screen share session in Teams is started. Same thing happens with a conference call when a screen share is started. The issue is observed in Teams Classic version.
Solution
Please advise users to update to Teams 2.0 which doesn't have the above mentioned issues.